SendGrid Outbound Email Temporarily Blocked for Doctible

Incident Report for Doctible

Resolved

Emails appear to be sending as normal
Posted Dec 15, 2025 - 16:08 PST

Monitoring

Emails have been restored by our email vendor. We are monitoring the situation to understand the impact of the emails that were pending during the outage.
Posted Dec 15, 2025 - 13:57 PST

Identified

All customers using outbound email are affected. SendGrid, our third-party email provider, has temporarily blocked outbound email sending from our account due to suspicious activity from a compromised user account.

We have identified and blocked the compromised Doctible user account. We have contacted SendGrid and are working with them to restore outbound email service.
Posted Dec 15, 2025 - 09:52 PST
This incident affected: Doctible Products (Patient Reminder Services, Review Manager, Recall, Campaigns, EasyFill).